Xavier app site is slow
Incident Report for Dext Precision
Resolved
The situation with our web hosting provider has now been resolved. We've done all we can to help the site along in the meantime, and we'll be monitoring over the next few hours to make sure it's all happy. Thanks for bearing with us!
Posted Jun 17, 2019 - 10:56 UTC
Update
Our web hosting provider has been confirmed to be having some DNS issues, and they are working on this currently. We will update you as soon as we know anything further.
Posted Jun 17, 2019 - 09:10 UTC
Update
We are continuing to investigate this issue.
Posted Jun 17, 2019 - 08:47 UTC
Investigating
We are currently investigating user reports that app.xavier-analytics.com is loading unusually slowly. We're really sorry for any inconvenience caused by these performance issues, and we'll update you as soon as we can locate the reason why this might be happening.
Posted Jun 17, 2019 - 08:45 UTC
This incident affected: Main Xavier App.